Tuesday, April 26, 2011

Technician tenacity

Today’s technicians today have to be patient, tenacious and smart in order to diagnose many problems on today’s cars ….

This one is a good example. A client brought us her 2006 Audi A6 Quattro. She said the check engine light was on and car seemed to run a little sluggish.

Master technician Bob Toti began by attaching our VAG tester (the special Audi test tool) to the vehicle’s diagnostic port to read any stored faults. The tester showed two current faults: a cam sensor bank on 2 fault and a small evaporative leak. He also found an intermittent or old low pressure fuel sensor fault.

Whenever you find “current” faults you can verify them by clearing them and seeing how they reset themselves. That’s what we did in this case. Bob found the cam sensor fault came back immediately so he focused on that problem first. After verifying that the voltages at the sensor were okay and wiring from engine module was okay too, he swapped with the identical sensor from bank 1. The result? The same fault occurred. At this point the tech verified that the engine module was reading information from that sensor, but was this information correct?

Master technician Danny Ferrari now took over solving the Audi cam sensor fault mystery while Bob concentrated on other work in the shop.

Using actual values in the VAG, the tech found the intake cam in bank 2 was out of position by almost 10 degrees, when the spec was less than half a degree.

Careful and thoughtful technicians found that this little
bit of screen stuck in the valve was giving the customer
big headaches.
 
This car’s cam advance system is able to advance or retard all the 4 cams by letting oil in and out of four solenoid valves. For some reason one of these cams was working at the wrong advance angle, or at least that’s what the sensor was telling us. The next step was checking the actual cam advance valve by opening up the engine and comparing the observed position of the cam with the position reported by the sensor. That check showed the sensor to be telling the truth – the cam was really out of position. But the question of why that might be remained unanswered. So we removed the adjusting solenoid. When we took it apart we found debris tucked into the valve, between the sleeve and the moving part of the valve. The debris looked like really small bits of metal screen. The debris was causing the position problem by not letting the valve close all the way.

Replacing the valve fixed the problem. A long road test after repair did not reveal any other faults. The other codes – the ones we’d read on first examination – never returned. We changed the oil and sent the car down the road with a very happy owner.

Why would this valve go bad on a 28,000 mile car? I wish I knew. There was no evidence of neglect or abuse inside the motor, though some of the stresses that might have led to this failure would not leave a visible trace. It’s also possible the car was filled with the wrong oil earlier in its life. Perhaps the valve was defective from new. It’s a one-of-a-kind problem in this shop. And more and more, that’s what we see. One-off problems other people can’t fix are becoming our stock in trade.

No comments: